Issues with Live Chat
Incident Report for Taxi for Email
Resolved
This issue has now been resolved.
Posted 3 months ago. Aug 16, 2017 - 17:50 BST
Identified
Some Taxi users are reporting that live chat isn’t loading for them. We’re working with Intercom on this now.
Posted 3 months ago. Aug 16, 2017 - 15:51 BST