Intermittent display issue
Incident Report for Taxi for Email
Resolved
this issue is now resolved
Posted over 2 years ago. May 19, 2015 - 11:43 BST
Monitoring
Some users are reporting an intermittent display issue with the app. We are pushing a fix for this now.
Posted over 2 years ago. May 19, 2015 - 11:16 BST