Interface layout issue
Incident Report for Taxi for Email
Resolved
This issue has been resolved.
Posted over 2 years ago. Mar 17, 2015 - 13:22 GMT
Identified
There is an intermittent issue happening with the display of the front-end interface. All content and data is safe.

A fix is being deployed shortly.
Posted over 2 years ago. Mar 17, 2015 - 12:22 GMT