Taxi Website Down
Incident Report for Taxi for Email
Resolved
this issue has been resolved
Posted over 1 year ago. Jul 28, 2016 - 11:49 BST
Identified
The Taxi website is currently down, we are working to resolve this.

This does not affect the Taxi app, and you can log in at https://my.emailcms.net/login/
Posted over 1 year ago. Jul 28, 2016 - 10:35 BST