Interface running slow
Incident Report for Taxi for Email
Resolved
We had an AWS related issue, which we have now fixed.
Posted almost 2 years ago. Dec 18, 2015 - 15:33 GMT
Identified
The Taxi editor interface is running slow and/or inaccessible for some users. We are investigating this now and hope to be back shortly.
Posted almost 2 years ago. Dec 18, 2015 - 14:37 GMT