Slow interface
Incident Report for Taxi for Email
Resolved
This issue has been resolved and a fix has been added to avoid it in future.
Posted over 1 year ago. Apr 06, 2016 - 15:08 BST
Identified
We have an issue with one of our servers which may cause Taxi to run slowly. We have pushed an update and this will be resolved shortly
Posted over 1 year ago. Apr 06, 2016 - 14:16 BST