Issues with Taxi Editor
Incident Report for Taxi for Email
Resolved
this issue is resolved
Posted over 1 year ago. Aug 07, 2017 - 11:59 BST
Identified
We are investigating some reported issues with the Taxi editor this morning. We will post further updates shortly.
Posted over 1 year ago. Aug 07, 2017 - 09:59 BST