Litmus Connector running slowly
Incident Report for Taxi for Email
Resolved
This issue has been resolved.
Posted over 1 year ago. Mar 15, 2016 - 13:21 GMT
Monitoring
Some users are experiencing intermittent issues connecting to the Litmus API. We are monitoring the issue.
Posted over 1 year ago. Mar 15, 2016 - 09:04 GMT