Template uploading
Incident Report for Taxi for Email
Resolved
This issue is now resolved, happy Easter!
Posted over 2 years ago. Apr 02, 2015 - 17:46 BST
Monitoring
There are intermittent problems uploading/updating new templates. We are working on a fix now.
Posted over 2 years ago. Apr 02, 2015 - 16:40 BST