Ongoing issues accessing taxiforemail.com
Incident Report for Taxi for Email
Resolved
This incident has been resolved.
Posted 5 months ago. Oct 24, 2018 - 09:18 BST
Update
We are continuing to investigate this issue.
Posted 5 months ago. Oct 24, 2018 - 09:09 BST
Investigating
Our website is unavailable for some users, this is due to an issue our web host is experiencing. We're working with them to restore service.
Posted 5 months ago. Oct 24, 2018 - 09:08 BST
This incident affected: Web Application.