taxiforemail.com unavailable for some users
Incident Report for Taxi for Email
Resolved
This issue seems to be resolved.
Posted 5 months ago. Feb 27, 2018 - 23:46 GMT
Investigating
There are widespread DNS issues affecting Google’s public DNS servers. As a result, http://taxiforemail.com may not be available for some users.

Access to the Taxi app should be unaffected by this issue. You can log into Taxi at https://my.emailcms.net

For more coverage, check hover’s status page: http://hoverstatus.com/
Posted 5 months ago. Feb 27, 2018 - 21:24 GMT