Taxi isn't saving content for some people
Incident Report for Taxi for Email
Resolved
We've made an update to Taxi and your saved content should now appear as expected. You shouldn't need to re-save or re-clone anything.
Posted Jan 26, 2021 - 15:43 CET
Identified
We've identified an issue with saving content in the Taxi platform - which we're working on solving. We'll share a further update as soon as we can.
Posted Jan 26, 2021 - 15:36 CET
This incident affected: Taxi for Email Platform (WebUI).