Ongoing issues accessing taxiforemail.com
Incident Report for Taxi for Email
Resolved
This issue has been resolved.
Posted 3 months ago. May 04, 2018 - 22:53 BST
Identified
the issues with our webhost are still intermittently happening. We are working with our current hosts and also moving to a new platform for taxiforemail.com

Please note that Taxi app is unaffected and can still be accessed at: https://my.emailcms.net/login
Posted 3 months ago. May 04, 2018 - 09:11 BST
Investigating
We are still seeing intermittent issues for users accessing taxiforemail.com. We are working with MediaTemple, our web hosts, to resolve this.

This is related to an earlier issue:
http://status.taxiforemail.com/incidents/21ny69qbh165

Please note that Taxi app is unaffected and can still be accessed at: https://my.emailcms.net/login
Posted 3 months ago. May 03, 2018 - 23:02 BST